summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2005-10-12 13:27:08 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2005-10-12 13:27:08 +0000
commitc2c6f999b78be193cad9a74271877f2bc6891c1f (patch)
tree1b583d541cee863bb9238f896f74cc978d3a5393 /configure.ac
parent904dd7fcb4fe358e8ee6cdc28a1fafdeaf672182 (diff)
* added support in autoconf for multiple architecture
* only compile netlink support on linux git-svn-id: file:///home/lennart/svn/public/avahi/trunk@734 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 427dcdb..8db8c53 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,6 +57,39 @@ AC_PROG_LIBTOOL
ACX_PTHREAD(,AC_MSG_ERROR([Missing POSIX Threads support]))
#
+# Host specific stuffs
+#
+case "$host" in
+ *-netbsd* | *-knetbsd*-gnu)
+ AC_DEFINE([NETBSD],[],[ Support for NetBSD])
+ avahi_platform=netbsd
+ ;;
+ *-openbsd*)
+ AC_DEFINE([OPENBSD],[],[ Support for OpenBSD])
+ avahi_platform=openbsd
+ ;;
+ *-solaris*)
+ AC_DEFINE([SOLARIS],[],[ Support for Sun Solaris])
+ avahi_platform=solaris
+ ;;
+ *-linux*)
+ AC_DEFINE([LINUX],[],[ Support for GNU/Linux])
+ AC_DEFINE([HAVE_NETLINK],[],[ Support for netlink.h])
+ avahi_platform=linux
+ ;;
+ *-freebsd* | *-kfreebsd*-gnu)
+ AC_DEFINE([FREEBSD],[],[ Support for FreeBSD])
+ avahi_platform=freebsd
+ ;;
+ *-apple-darwin*)
+ AC_DEFINE([DARWIN],[],[ Support for AppleDarwin])
+ avahi_platform=darwin
+ ;;
+esac
+
+AM_CONDITIONAL(HAVE_NETLINK, [ test x"$avahi_platform" = xlinux ])
+
+#
# Detecting the linux distribution for specific things like init scripts.
#
AC_ARG_WITH(distro, AS_HELP_STRING([--with-distro=DISTRO],[Specify the Linux distribution to target: One of debian, gentoo, archlinux or none]))