summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTrent Lloyd <lathiat@bur.st>2005-08-24 09:38:42 +0000
committerTrent Lloyd <lathiat@bur.st>2005-08-24 09:38:42 +0000
commitb937e3db60682cec5fec1119cbbb8bf0ae31834a (patch)
treeedb8583301a1ba755dd68977a327943aae2b7cc6 /configure.ac
parent02454f166de8f9199a79a7b731124ba27f263b6b (diff)
* Merge r433:436 from trunk into branches/netlink-integrationnetlink-abstraction
git-svn-id: file:///home/lennart/svn/public/avahi/branches/netlink-abstraction@437 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index d53dc76..c041dbc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,14 +59,14 @@ fi
with_distro=`echo ${with_distro} | tr '[[:upper:]]' '[[:lower:]]' `
if test "z$with_distro" = "z"; then
- AC_MSG_ERROR([Linux distribution autodetection failed, you must specify the distribution to target using --with-distro=DISTRO])
+ AC_MSG_ERROR([Linux distribution autodetection failed, you must specify the distribution to target using --with-distro=DISTRO, set DISTRO to none if your distribution is not supported.])
exit 1
else
case $with_distro in
- debian|gentoo|archlinux)
+ debian|gentoo|archlinux|none)
;;
*)
- AC_MSG_ERROR([Your distribution (${with_distro}) is not yet supported, init scripts and dbus configuration will not be installed! (patches welcome)])
+ AC_MSG_ERROR([Your distribution (${with_distro}) is not yet supported, init scripts and dbus configuration will not be installed! (patches welcome), you can specify --with-distro=none to skip this check])
;;
esac
fi
@@ -140,6 +140,14 @@ AC_FUNC_STAT
AC_TYPE_MODE_T
AC_TYPE_PID_T
+# Check for pkg-config manually first, as if its not installed the
+# PKG_PROG_PKG_CONFIG macro won't be defined.
+AC_CHECK_PROG(have_pkg_config, pkg-config, yes, no)
+
+if test x"$have_pkg_config" == xno; then
+ AC_MSG_ERROR(pkg-config is required to install this program)
+fi
+
PKG_PROG_PKG_CONFIG
#