summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTrent Lloyd <lathiat@bur.st>2005-06-08 18:55:06 +0000
committerTrent Lloyd <lathiat@bur.st>2005-06-08 18:55:06 +0000
commitce170511234a040ea6f418b168beb3a6e51a1f2c (patch)
tree1e2dc7c1998185f77ff841f5e1d17a09fdfa507d /configure.ac
parent1f2b8ac4ae09b15a0a6d1f7633f888654fd271dd (diff)
* Patch by Ross Burton to enable conditional use of dbus (--enable-dbus=no), disables daemon build
* Remove doxygen from EXTRA_DIST as its built by default now git-svn-id: file:///home/lennart/svn/public/avahi/trunk@107 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 18 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index b5492c5..1a295d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,11 +62,6 @@ PKG_CHECK_MODULES(GLIB20, [ glib-2.0 >= 2.4.0 ])
AC_SUBST(GLIB20_CFLAGS)
AC_SUBST(GLIB20_LIBS)
-# Check for DBUS
-PKG_CHECK_MODULES(DBUS, [ dbus-1 >= 0.23, dbus-glib-1 >= 0.23 ])
-AC_SUBST(DBUS_CFLAGS)
-AC_SUBST(DBUS_LIBS)
-
AC_ARG_ENABLE(gtk,
AC_HELP_STRING([--enable-gtk],[use GTK+ (default=yes)]),
[case "${enableval}" in
@@ -100,6 +95,24 @@ AC_ARG_ENABLE(doxygen,
AM_CONDITIONAL(ENABLE_DOXYGEN, test "x$ENABLE_DOXYGEN" = "xyes")
+AC_ARG_ENABLE(dbus,
+ AC_HELP_STRING([--enable-dbus],[use DBus (default=yes)]),
+ [case "${enableval}" in
+ yes) ENABLE_DBUS=yes ;;
+ no) ENABLE_DBUS=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-dbus) ;;
+ esac],
+ [ENABLE_DBUS=yes]) dnl Default value
+
+if test "x$ENABLE_DBUS" = "xyes"; then
+ PKG_CHECK_MODULES(DBUS, [ dbus-glib-1 >= 0.23])
+ AC_SUBST(DBUS_CFLAGS)
+ AC_SUBST(DBUS_LIBS)
+fi
+
+AM_CONDITIONAL(ENABLE_DBUS, test "x$ENABLE_DBUS" = "xyes")
+
+
# If using GCC specify some additional parameters
if test "x$GCC" = "xyes" ; then
CFLAGS="$CFLAGS -pipe -W -Wall -pedantic"