summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTrent Lloyd <lathiat@bur.st>2005-07-04 20:36:12 +0000
committerTrent Lloyd <lathiat@bur.st>2005-07-04 20:36:12 +0000
commit05b0b1d0aad6b9613fff841000815a05486f130b (patch)
treeb478e0a69cc03cddcb0d3cac3939561f268617d3 /configure.ac
parent89b7a2522394dc6c546156b35d197ee00ca6a016 (diff)
* Remove support for dbus 0.23.
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@162 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 65c0b11..4ae5172 100644
--- a/configure.ac
+++ b/configure.ac
@@ -125,7 +125,7 @@ AC_ARG_ENABLE(dbus,
if test "x$ENABLE_DBUS" = "xyes"; then
AC_DEFINE(ENABLE_DBUS, 1, [Whether to use DBUS or not])
- PKG_CHECK_MODULES(DBUS, [ dbus-glib-1 >= 0.23])
+ PKG_CHECK_MODULES(DBUS, [ dbus-glib-1 >= 0.30])
AC_ARG_WITH(dbus-sys, [ --with-dbus-sys=<dir> where D-BUS system.d directory is])
@@ -137,10 +137,6 @@ if test "x$ENABLE_DBUS" = "xyes"; then
AC_SUBST(DBUS_SYS_DIR)
AC_DEFINE_UNQUOTED(DBUS_SYSTEMD_DIR, `eval echo $DBUS_SYS_DIR` , [Where system.d dir for DBUS is])
- if pkg-config dbus-1 --atleast-version=0.30 ; then
- AC_DEFINE(DBUS_USE_NEW_API, 1, [Whether to use the new API for DBUS 0.30])
- fi
-
AC_SUBST(DBUS_CFLAGS)
AC_SUBST(DBUS_LIBS)
fi