summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2005-06-30 22:55:20 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2005-06-30 22:55:20 +0000
commitaab15b8d9a9d5d869659915c3d0995929ae4179b (patch)
tree4a2bf6387e835d17e94ad28b9beaf5a2992e401d /configure.ac
parentb7ca2e3b1fe5d7a4134728aa8cc88d9fb363b77c (diff)
* moved AVAHI_RUNTIME_DIR and AVAHI_SOCKET in configure.ac
* avahi-dnsconf and avahi use them for pid and socket file * check that ${prefix} is fully expanded in config.h * cosmetic changes in configure.ac git-svn-id: file:///home/lennart/svn/public/avahi/trunk@158 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 15 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 1cedd10..05b48c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,7 @@ AC_PROG_CPP
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_MAKE_SET
+AC_PROG_GCC_TRADITIONAL
# libtool stuff
AC_PROG_LIBTOOL
@@ -51,11 +52,12 @@ AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h limits.h netinet/in.h stdlib.h
AC_C_CONST
AC_TYPE_SIZE_T
AC_HEADER_TIME
+AC_HEADER_SYS_WAIT
# Checks for library functions.
AC_FUNC_MEMCMP
AC_FUNC_SELECT_ARGTYPES
-AC_CHECK_FUNCS([gethostname memchr memmove memset mkdir select socket strchr strcspn strerror strrchr strstr uname setresuid setreuid])
+AC_CHECK_FUNCS([gethostname memchr memmove memset mkdir select socket strchr strcspn strdup strerror strrchr strspn strstr uname setresuid setreuid])
AC_FUNC_CHOWN
AC_FUNC_STAT
@@ -89,14 +91,12 @@ if test "x$ENABLE_GTK" = "xyes"; then
DATADIRNAME=share
if test "x${prefix}" = "xNONE"; then
- AC_DEFINE_UNQUOTED(INTERFACES_DIR, "${ac_default_prefix}/${DATADIRNAME}/${PACKAGE}/interfaces/", [path where glade files will be installed])
interfacesdir="${ac_default_prefix}/${DATADIRNAME}/${PACKAGE}/interfaces/"
- AC_SUBST(interfacesdir)
else
- AC_DEFINE_UNQUOTED(INTERFACES_DIR, "${prefix}/${DATADIRNAME}/${PACKAGE}/interfaces/", [path where glade files will be installed])
interfacesdir="${prefix}/${DATADIRNAME}/${PACKAGE}/interfaces/"
- AC_SUBST(interfacesdir)
fi
+ AC_DEFINE_UNQUOTED(INTERFACES_DIR, "${interfacesdir}", [path where glade files will be installed])
+ AC_SUBST(interfacesdir)
fi
AM_CONDITIONAL(ENABLE_GTK, test "x$ENABLE_GTK" = "xyes")
@@ -134,7 +134,7 @@ if test "x$ENABLE_DBUS" = "xyes"; then
DBUS_SYS_DIR="${sysconfdir}/dbus-1/system.d"
fi
AC_SUBST(DBUS_SYS_DIR)
- AC_DEFINE_UNQUOTED(DBUS_SYSTEMD_DIR, "$DBUS_SYS_DIR", [Where system.d dir for DBUS is])
+ AC_DEFINE_UNQUOTED(DBUS_SYSTEMD_DIR, `eval echo $DBUS_SYS_DIR` , [Where system.d dir for DBUS is])
if pkg-config dbus-1 --atleast-version=0.30 ; then
AC_DEFINE(DBUS_USE_NEW_API, 1, [Whether to use the new API for DBUS 0.30])
@@ -184,9 +184,7 @@ if test "z$with_distro" = "z"; then
exit 1
else
case $with_distro in
- debian)
- ;;
- gentoo)
+ debian|gentoo)
;;
*)
echo "Your distribution (${with_distro}) is not yet supported! (patches welcome)"
@@ -222,6 +220,14 @@ fi
AC_SUBST(AVAHI_GROUP)
AC_DEFINE_UNQUOTED(AVAHI_GROUP,"$AVAHI_GROUP", [Group for Avahi])
+#
+# Avahi runtime dir
+#
+avahi_runtime_dir=`eval echo ${localstatedir}/run/avahi`
+AC_DEFINE_UNQUOTED(AVAHI_RUNTIME_DIR, "${avahi_runtime_dir}", [path where pid and socket will be stored])
+AC_DEFINE_UNQUOTED(AVAHI_SOCKET, "${avahi_runtime_dir}/socket", [path for avahi socket])
+
+
AC_CONFIG_FILES([
Makefile
avahi-core.pc