summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTrent Lloyd <lathiat@bur.st>2005-08-30 11:22:31 +0000
committerTrent Lloyd <lathiat@bur.st>2005-08-30 11:22:31 +0000
commit3701706c65de0f0b5f652b0cd37670c03800b4a2 (patch)
treee32dad3f3cd91ab5ff8fb89749f09f743371d087 /configure.ac
parentbe10803e4dee7cb430423248f12685353c1ea166 (diff)
* Fix building of python scripts to exclude things needing DBUS or GTK if they are disabled, including fixing configure.ac not to error in these cases.
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@503 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5daa502..5cab52c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -342,8 +342,12 @@ AC_ARG_ENABLE(python,
if test "x$HAVE_PYTHON" = "xyes" ; then
AM_PATH_PYTHON([2.4])
- AM_CHECK_PYMOD(gtk,,,[AC_MSG_ERROR(Could not find Python module pygtk)])
- AM_CHECK_PYMOD(dbus,,,[AC_MSG_ERROR(Could not find Python module dbus)])
+ if test "x$HAVE_GTK" = "xyes" ; then
+ AM_CHECK_PYMOD(gtk,,,[AC_MSG_ERROR(Could not find Python module pygtk)])
+ fi
+ if test "x$HAVE_DBUS" = "xyes" ; then
+ AM_CHECK_PYMOD(dbus,,,[AC_MSG_ERROR(Could not find Python module dbus)])
+ fi
AM_CHECK_PYMOD(socket,,,[AC_MSG_ERROR(Could not find Python module socket)])
AM_CHECK_PYMOD(dbm,,,[AC_MSG_ERROR(Could not find Python module dbm)])
AM_CHECK_PYMOD(anydbm,,,[AC_MSG_ERROR(Could not find Python module anydbm)])