summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-10-02 02:18:11 +0000
committerLennart Poettering <lennart@poettering.net>2005-10-02 02:18:11 +0000
commit7b7a022127d14b3a83d042c2aa52c76ec90554d2 (patch)
tree460d258950fbf20f8aa6005f9323e2260fd2078b /configure.ac
parentd3e893754d3158b72d488e515535dfcac980e1c3 (diff)
* add pthreads autoconf scripts
* add bonjour compatiblity layer (only browsing, resolving for now. the complicated stuff is done, missing parts will follow soon) git-svn-id: file:///home/lennart/svn/public/avahi/trunk@672 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d047e5c..c70ab2d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,7 @@ AC_SUBST(LIBAVAHI_CLIENT_VERSION_INFO, [2:0:1])
AC_SUBST(LIBAVAHI_GLIB_VERSION_INFO, [0:1:0])
AC_SUBST(LIBAVAHI_QT3_VERSION_INFO, [0:0:0])
AC_SUBST(LIBAVAHI_QT4_VERSION_INFO, [0:0:0])
+AC_SUBST(LIBAVAHI_COMPAT_BONJOUR_VERSION_INFO, [0:0:0])
if type -p stow > /dev/null && test -d /usr/local/stow ; then
AC_MSG_NOTICE([*** Found /usr/local/stow: default install prefix set to /usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION} ***])
@@ -53,6 +54,8 @@ AC_PROG_GCC_TRADITIONAL
# libtool stuff
AC_PROG_LIBTOOL
+ACX_PTHREAD(,AC_MSG_ERROR([Missing POSIX Threads support]))
+
#
# Detecting the linux distribution for specific things like init scripts.
#
@@ -552,6 +555,7 @@ man/Makefile
tests/Makefile
service-type-database/Makefile
avahi-sharp/Makefile
+compat-bonjour/Makefile
])
AC_OUTPUT