summaryrefslogtreecommitdiffstats
path: root/initscript/darwin/Makefile.am
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2005-11-14 23:56:41 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2005-11-14 23:56:41 +0000
commit7ff7db1bd0b18a82284016c3a528bb2d45ec6b09 (patch)
tree5f09d201b996df8f54b501dae65f2d123ad47161 /initscript/darwin/Makefile.am
parent01bba04c7ba0dfe48723f489349638a2b063df1a (diff)
* add preliminary plist scripts for darwin (equivalent of initscripts)
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@964 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'initscript/darwin/Makefile.am')
-rw-r--r--initscript/darwin/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/initscript/darwin/Makefile.am b/initscript/darwin/Makefile.am
new file mode 100644
index 0000000..facc9d5
--- /dev/null
+++ b/initscript/darwin/Makefile.am
@@ -0,0 +1,40 @@
+# $Id$
+
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+initddir = /System/Library/LaunchDaemons/
+
+EXTRA_DIST = \
+ org.freedesktop.avahi-daemon.plist.in \
+ org.freedesktop.avahi-dnsconfd.plist.in
+
+initd_SCRIPTS = \
+ org.freedesktop.avahi-daemon.plist \
+ org.freedesktop.avahi-dnsconfd.plist
+
+CLEANFILES = \
+ org.freedesktop.avahi-daemon.plist \
+ org.freedesktop.avahi-dnsconfd.plist
+
+org.freedesktop.avahi-daemon.plist: org.freedesktop.avahi-daemon.plist.in
+ sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod +x $@
+
+org.freedesktop.avahi-dnsconfd.plist: org.freedesktop.avahi-dnsconfd.plist.in
+ sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod +x $@