summaryrefslogtreecommitdiffstats
path: root/initscript/debian/Makefile.am
diff options
context:
space:
mode:
authorTrent Lloyd <lathiat@bur.st>2005-08-23 08:39:01 +0000
committerTrent Lloyd <lathiat@bur.st>2005-08-23 08:39:01 +0000
commit78c4d691610a48ac2c2f12172ae24c3d096b415e (patch)
tree0b4fe6e65faf814f8214176fac1dd5744a57ade5 /initscript/debian/Makefile.am
parentda5014cb5f3d06271ae79dc28354a03c7392cf0f (diff)
* generate initscript/archlinux/Makefile
* Fix archlinux CFLAG err, fix. * Rename the initscript dirs to all lowercase. git-svn-id: file:///home/lennart/svn/public/avahi/trunk@407 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'initscript/debian/Makefile.am')
-rw-r--r--initscript/debian/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/initscript/debian/Makefile.am b/initscript/debian/Makefile.am
new file mode 100644
index 0000000..4165ad3
--- /dev/null
+++ b/initscript/debian/Makefile.am
@@ -0,0 +1,40 @@
+# $Id$
+
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+initddir = $(sysconfdir)/init.d
+
+EXTRA_DIST = \
+ avahi-daemon.in \
+ avahi-dnsconfd.in
+
+initd_SCRIPTS = \
+ avahi-daemon \
+ avahi-dnsconfd
+
+CLEANFILES = \
+ avahi-daemon \
+ avahi-dnsconfd
+
+avahi-daemon: avahi-daemon.in
+ sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod +x $@
+
+avahi-dnsconfd: avahi-dnsconfd.in
+ sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod +x $@