summaryrefslogtreecommitdiffstats
path: root/initscript/freebsd/Makefile.am
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2005-11-19 19:49:24 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2005-11-19 19:49:24 +0000
commit002299d20901eaea6c7492670b050e4893271acf (patch)
tree71283247c6f1f710631eee4001f7aba147342310 /initscript/freebsd/Makefile.am
parent238c921e17a59c54f381e4fd862c3883c73c639a (diff)
* Added FreeBSD rc.d scripts with the permission of its authors.
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1017 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'initscript/freebsd/Makefile.am')
-rw-r--r--initscript/freebsd/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/initscript/freebsd/Makefile.am b/initscript/freebsd/Makefile.am
new file mode 100644
index 0000000..0ee75d5
--- /dev/null
+++ b/initscript/freebsd/Makefile.am
@@ -0,0 +1,43 @@
+# $Id$
+
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+initddir = $(sysconfdir)/rc.d
+
+EXTRA_DIST = \
+ avahi-daemon.sh.in \
+ avahi-dnsconfd.sh.in
+
+initd_SCRIPTS = \
+ avahi-daemon.sh \
+ avahi-dnsconfd.sh
+
+CLEANFILES = \
+ avahi-daemon.sh \
+ avahi-dnsconfd.sh
+
+avahi-daemon.sh: avahi-daemon.sh.in
+ sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod +x $@
+
+avahi-dnsconfd.sh: avahi-dnsconfd.sh.in
+ sed \
+ -e 's,@sbindir\@,$(sbindir),g' \
+ -e 's,@sysconfdir\@,$(sysconfdir),g' \
+ $< > $@
+ chmod +x $@