summaryrefslogtreecommitdiffstats
path: root/initscript/mandriva/Makefile.am
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2006-01-20 21:00:10 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2006-01-20 21:00:10 +0000
commit020844b4b4c307f82692efa6f431081e66d3a7fd (patch)
treef729eef4dbc96329c5db5419a75d247eafa97ffc /initscript/mandriva/Makefile.am
parent8835db5cfb321e810c316ad263884eee3c76a879 (diff)
* Adding the missing files for Mandriva init.d
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@1088 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'initscript/mandriva/Makefile.am')
-rw-r--r--initscript/mandriva/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/initscript/mandriva/Makefile.am b/initscript/mandriva/Makefile.am
new file mode 100644
index 0000000..10fd4cf
--- /dev/null
+++ b/initscript/mandriva/Makefile.am
@@ -0,0 +1,34 @@
+# $Id: Makefile.am 838 2005-10-22 21:23:02Z lennart $
+
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+initddir = $(sysconfdir)/rc.d/init.d
+
+EXTRA_DIST = avahi-daemon.in avahi-dnsconfd.in
+
+initd_SCRIPTS = avahi-daemon avahi-dnsconfd
+
+CLEANFILES = avahi-daemon avahi-dnsconfd
+
+avahi-daemon: avahi-daemon.in
+ sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod +x $@
+
+avahi-dnsconfd: avahi-dnsconfd.in
+ sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod +x $@