summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-08-14 01:26:19 +0000
committerLennart Poettering <lennart@poettering.net>2005-08-14 01:26:19 +0000
commit7934ca5e102693ba02d9ca6dcdee4960f2ba1a64 (patch)
tree441d008ef53ff24f1f18630ccede9d1a80847e77 /tests/Makefile.am
parentb789f76475170c84fce85383279aa8f683ad1ff9 (diff)
* add C++ test
* add more autoconf checks git-svn-id: file:///home/lennart/svn/public/avahi/trunk@313 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..f300c6c
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,39 @@
+# $Id$
+#
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+AM_CFLAGS= \
+ -I$(top_srcdir)
+
+# GLIB 2.0
+AM_CFLAGS+=$(GLIB20_CFLAGS)
+AM_LDADD=$(GLIB20_LIBS)
+
+noinst_PROGRAMS = \
+ c-plus-plus-test
+
+c_plus_plus_test_SOURCES = \
+ c-plus-plus-test.cc
+
+c_plus_plus_CFLAGS = $(AM_CFLAGS)
+c_plus_plus_test_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la ../avahi-core/libavahi-core.la
+
+EXTRA_DIST=c-plus-plus-test-gen.py
+
+gen:
+ python ./c-plus-plus-test-gen.py > c-plus-plus-test.cc