summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index bc51911..0411c74 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,6 +45,7 @@ EXTRA_DIST = \
avahi-qt3.pc.in \
avahi-qt4.pc.in \
avahi-sharp.pc.in \
+ avahi-ui-sharp.pc.in \
avahi-compat-libdns_sd.pc.in \
avahi-compat-howl.pc.in \
avahi-ui.pc.in
@@ -70,7 +71,8 @@ SUBDIRS = \
avahi-compat-libdns_sd \
avahi-compat-howl \
avahi-autoipd \
- avahi-ui
+ avahi-ui \
+ avahi-ui-sharp
DX_INPUT = \
$(srcdir)/avahi-common/address.h \
@@ -181,14 +183,19 @@ endif
if HAVE_MONO
-pkgconfig_DATA += avahi-sharp.pc
+pkgconfig_DATA += avahi-sharp.pc avahi-ui-sharp.pc
avahi-sharp.pc: avahi-sharp.pc.in
sed -e 's,@prefix\@,$(prefix),g' \
-e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
-e 's,@libdir\@,$(libdir),g' $< > $@
-CLEANFILES += avahi-sharp.pc
+avahi-ui-sharp.pc: avahi-ui-sharp.pc.in
+ sed -e 's,@prefix\@,$(prefix),g' \
+ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
+ -e 's,@libdir\@,$(libdir),g' $< > $@
+
+CLEANFILES += avahi-sharp.pc avahi-ui-sharp.pc
endif