summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 13 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 5690c5b..06ffd25 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -137,6 +137,19 @@ CLEANFILES += avahi-compat-libdns_sd.pc
endif
+if HAVE_MONO
+
+pkgconfig_DATA += avahi-sharp.pc
+
+avahi-sharp.pc: avahi-sharp.pc.in
+ sed -e 's,@prefix\@,$(prefix),g' \
+ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
+ -e 's,@libdir\@,$(libdir),g' $< > $@
+
+CLEANFILES += avahi-sharp.pc
+
+endif
+
endif
if HAVE_GLIB
@@ -175,21 +188,6 @@ CLEANFILES += avahi-qt4.pc
endif
-if HAVE_MONO
-if HAVE_DBUS
-
-pkgconfig_DATA += avahi-sharp.pc
-
-avahi-sharp.pc: avahi-sharp.pc.in
- sed -e 's,@prefix\@,$(prefix),g' \
- -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
- -e 's,@libdir\@,$(libdir),g' $< > $@
-
-CLEANFILES += avahi-sharp.pc
-
-endif
-endif
-
MOSTLYCLEANFILES = $(DX_CLEANFILES)
DISTCHECK_CONFIGURE_FLAGS = \