summaryrefslogtreecommitdiffstats
path: root/avahi-autoipd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-autoipd/Makefile.am')
-rw-r--r--avahi-autoipd/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/avahi-autoipd/Makefile.am b/avahi-autoipd/Makefile.am
index 11e6493..7589688 100644
--- a/avahi-autoipd/Makefile.am
+++ b/avahi-autoipd/Makefile.am
@@ -36,15 +36,30 @@ sbin_PROGRAMS = avahi-autoipd
avahi_autoipd_SOURCES = \
main.c main.h \
../avahi-daemon/setproctitle.c ../avahi-daemon/setproctitle.h \
- iface.h iface-linux.c \
+ iface.h \
../avahi-common/malloc.h ../avahi-common/malloc.c \
../avahi-common/timeval.h ../avahi-common/timeval.c
avahi_autoipd_CFLAGS = $(AM_CFLAGS) $(LIBDAEMON_CFLAGS)
avahi_autoipd_LDADD = $(AM_LDADD) $(LIBDAEMON_LIBS)
+if TARGET_FREEBSD
+avahi_autoipd_SOURCES += iface-bsd.c
+avahi_autoipd_LDADD += -lpcap
+else
+avahi_autoipd_SOURCES += iface-linux.c
+endif
+
pkgsysconf_SCRIPTS=avahi-autoipd.action
+if TARGET_FREEBSD
+avahi-autoipd.action: avahi-autoipd.action.bsd
+ cp $< $@
+else
+avahi-autoipd.action: avahi-autoipd.action.linux
+ cp $< $@
+endif
+
if TARGET_DEBIAN
noinst_SCRIPTS = dhclient-enter-hook dhclient-exit-hook
@@ -78,4 +93,4 @@ endif
EXTRA_DIST=avahi-autoipd.action dhclient-enter-hook.in dhclient-exit-hook.in
-CLEANFILES=dhclient-enter-hook dhclient-exit-hook
+CLEANFILES=dhclient-enter-hook dhclient-exit-hook avahi-autoipd.action