summaryrefslogtreecommitdiffstats
path: root/avahi-common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-common/Makefile.am')
-rw-r--r--avahi-common/Makefile.am23
1 files changed, 18 insertions, 5 deletions
diff --git a/avahi-common/Makefile.am b/avahi-common/Makefile.am
index 7c41ea3..4310797 100644
--- a/avahi-common/Makefile.am
+++ b/avahi-common/Makefile.am
@@ -37,11 +37,8 @@ avahi_commoninclude_HEADERS = \
simple-watch.h \
gccmacro.h
-noinst_HEADERS = llist.h
-
-if ENABLE_DBUS
-noinst_HEADERS += dbus.h
-endif
+noinst_HEADERS = \
+ llist.h
noinst_PROGRAMS = \
strlst-test \
@@ -105,3 +102,19 @@ timeval_test_CFLAGS = $(AM_CFLAGS)
timeval_test_LDADD = $(AM_LDADD)
+
+if ENABLE_DBUS
+noinst_HEADERS += \
+ dbus.h \
+ dbus-watch-glue.h
+
+noinst_LIBRARIES = \
+ libdbus-watch-glue.a
+
+libdbus_watch_glue_a_SOURCES = \
+ dbus-watch-glue.h dbus-watch-glue.c
+
+libdbus_watch_glue_a_CFLAGS = $(AM_CFLAGS) $(DBUS_CFLAGS)
+
+endif
+