summaryrefslogtreecommitdiffstats
path: root/avahi-compat-howl/samples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-compat-howl/samples/Makefile.am')
-rw-r--r--avahi-compat-howl/samples/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/avahi-compat-howl/samples/Makefile.am b/avahi-compat-howl/samples/Makefile.am
index 14bbfb7..21d15a8 100644
--- a/avahi-compat-howl/samples/Makefile.am
+++ b/avahi-compat-howl/samples/Makefile.am
@@ -23,8 +23,11 @@ AM_CFLAGS=-I$(top_srcdir) -I$(top_srcdir)/avahi-compat-howl/include
AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
if HAVE_DBUS
+if ENABLE_COMPAT_HOWL
+if ENABLE_TESTS
noinst_PROGRAMS = browse resolve publish query
+endif
browse_SOURCES = \
browse.c
@@ -47,3 +50,4 @@ query_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS) -I $(srcdir)/include
query_LDADD = $(AM_LDADD) ../libavahi-compat-howl.la
endif
+endif