summaryrefslogtreecommitdiffstats
path: root/avahi-compat-libdns_sd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-compat-libdns_sd/Makefile.am')
-rw-r--r--avahi-compat-libdns_sd/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/avahi-compat-libdns_sd/Makefile.am b/avahi-compat-libdns_sd/Makefile.am
index fc1421b..f822135 100644
--- a/avahi-compat-libdns_sd/Makefile.am
+++ b/avahi-compat-libdns_sd/Makefile.am
@@ -32,7 +32,7 @@ avahi_compat_libdns_sd_HEADERS = dns_sd.h
lib_LTLIBRARIES = libdns_sd.la
if ENABLE_TESTS
-noinst_PROGRAMS = txt-test
+noinst_PROGRAMS = txt-test null-test
endif
libdns_sd_la_SOURCES = \
@@ -52,6 +52,14 @@ txt_test_SOURCES = \
txt_test_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS)
txt_test_LDADD = $(AM_LDADD) $(PTHREAD_LIBS) $(PTHREAD_CFLAGS) ../avahi-common/libavahi-common.la
+null_test_SOURCES = \
+ dns_sd.h \
+ compat.c \
+ null-test.c \
+ warn.c warn.h
+null_test_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS)
+null_test_LDADD = $(AM_LDADD) $(PTHREAD_LIBS) $(PTHREAD_CFLAGS) ../avahi-common/libavahi-common.la ../avahi-client/libavahi-client.la
+
# You can test the compatibility layer by sticking in mDNSResponder's
# dns-sd.c source here, naming it "libdns_sd-test.c" and running "make
# libdns_sd-test" manually. We do not distribute that file due to