summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index 0c6b1e2..7abc497 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -44,7 +44,8 @@ noinst_PROGRAMS = \
avahi-test \
conformance-test \
avahi-reflector \
- dns-test
+ dns-test \
+ timeeventq-test
libavahi_core_la_SOURCES = \
timeeventq.c timeeventq.h\
@@ -105,6 +106,13 @@ dns_test_SOURCES = \
dns_test_CFLAGS = $(AM_CFLAGS)
dns_test_LDADD = $(AM_LDADD) $(STATIC_COMMON_LDADD)
+timeeventq_test_SOURCES = \
+ timeeventq-test.c \
+ timeeventq.h timeeventq.c \
+ prioq.h prioq.c
+timeeventq_test_CFLAGS = $(AM_CFLAGS)
+timeeventq_test_LDADD = $(AM_LDADD) $(STATIC_COMMON_LDADD)
+
valgrind: avahi-test
libtool --mode=execute valgrind ./avahi-test