summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am17
1 files changed, 13 insertions, 4 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index e6708b6..cd22097 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -27,14 +27,15 @@ AM_LDADD=$(GLIB20_LIBS)
AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
lib_LTLIBRARIES = \
- libavahi-core.la
+ libavahi-core.la
noinst_PROGRAMS = \
dns-test \
domain-test \
prioq-test \
strlst-test \
- avahi-test
+ avahi-test \
+ alternative-test
libavahi_core_la_SOURCES = \
timeeventq.c timeeventq.h\
@@ -82,9 +83,17 @@ dns_test_CFLAGS = $(AM_CFLAGS)
dns_test_LDADD = $(AM_LDADD)
avahi_test_SOURCES = \
- avahi-test.c
+ avahi-test.c \
+ $(libavahi_core_la_SOURCES)
+
avahi_test_CFLAGS = $(AM_CFLAGS)
-avahi_test_LDADD = $(AM_LDADD) libavahi-core.la
+avahi_test_LDADD = $(AM_LDADD)
+
+alternative_test_SOURCES = \
+ alternative-test.c \
+ util.c util.h
+alternative_test_CFLAGS = $(AM_CFLAGS)
+alternative_test_LDADD = $(AM_LDADD)
valgrind: avahi-test
libtool --mode=execute valgrind ./avahi-test