summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am13
1 files changed, 2 insertions, 11 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index e15f295..c71d6ed 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -24,7 +24,6 @@ AM_CFLAGS+=$(GLIB20_CFLAGS)
AM_LDADD=$(GLIB20_LIBS)
# Import stuff from avahi-common
-AM_CFLAGS+=-I$(top_srcdir)/avahi-common
COMMON_LDADD=../avahi-common/libavahi-common.la
# This cool debug trap works on i386/gcc only
@@ -46,8 +45,7 @@ noinst_PROGRAMS = \
conformance-test \
avahi-reflector \
dns-test \
- timeeventq-test \
- timeval-test
+ timeeventq-test
libavahi_core_la_SOURCES = \
timeeventq.c timeeventq.h\
@@ -75,8 +73,8 @@ libavahi_core_la_SOURCES = \
log.c log.h \
browse-dns-server.c \
fdutil.h fdutil.c \
- timeval.h timeval.c \
util.c util.h
+
libavahi_core_la_CFLAGS = $(AM_CFLAGS)
libavahi_core_la_LIBADD = $(AM_LDADD) $(COMMON_LDADD)
@@ -113,17 +111,10 @@ dns_test_LDADD = $(AM_LDADD) $(COMMON_LDADD)
timeeventq_test_SOURCES = \
timeeventq-test.c \
timeeventq.h timeeventq.c \
- timeval.c timeval.h \
prioq.h prioq.c
timeeventq_test_CFLAGS = $(AM_CFLAGS)
timeeventq_test_LDADD = $(AM_LDADD) $(COMMON_LDADD)
-timeval_test_SOURCES = \
- timeval.c timeval.h \
- timeval-test.c
-timeval_test_CFLAGS = $(AM_CFLAGS)
-timeval_test_LDADD = $(AM_LDADD)
-
valgrind: avahi-test
libtool --mode=execute valgrind ./avahi-test