summaryrefslogtreecommitdiffstats
path: root/avahi-daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-daemon/Makefile.am')
-rw-r--r--avahi-daemon/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/avahi-daemon/Makefile.am b/avahi-daemon/Makefile.am
index ffcfa58..e1d64a4 100644
--- a/avahi-daemon/Makefile.am
+++ b/avahi-daemon/Makefile.am
@@ -100,12 +100,17 @@ avahi_daemon_SOURCES += \
dbus-sync-host-name-resolver.c \
dbus-sync-service-resolver.c \
dbus-record-browser.c \
- ../avahi-common/dbus.c ../avahi-common/dbus.h \
- ../avahi-common/dbus-watch-glue.c ../avahi-common/dbus-watch-glue.h
+ ../avahi-common/dbus.c ../avahi-common/dbus.h \
+ ../avahi-common/dbus-watch-glue.c ../avahi-common/dbus-watch-glue.h \
+ ../avahi-client/check-nss.c
avahi_daemon_LDADD += \
$(DBUS_LIBS)
+if HAVE_DLOPEN
+avahi_daemon_LDADD += -ldl
+endif
+
avahi_daemon_CFLAGS += $(DBUS_CFLAGS)
dbusservice_DATA = avahi-dbus.conf