summaryrefslogtreecommitdiffstats
path: root/avahi-discover-standalone/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-discover-standalone/Makefile.am')
-rw-r--r--avahi-discover-standalone/Makefile.am17
1 files changed, 14 insertions, 3 deletions
diff --git a/avahi-discover-standalone/Makefile.am b/avahi-discover-standalone/Makefile.am
index 7145e0f..5b93c42 100644
--- a/avahi-discover-standalone/Makefile.am
+++ b/avahi-discover-standalone/Makefile.am
@@ -42,12 +42,23 @@ avahi_discover_standalone_LDADD = \
../avahi-core/libavahi-core.la \
$(GLIB20_LIBS) $(GTK20_LIBS) $(GLADE20_LIBS)
-interfaces = \
- avahi-discover.glade
+interfaces_DATA = $(interfaces)
+
+else
+if HAVE_PYTHON
+if HAVE_DBUS
+
+# We need this for the python version of avahi-discover
interfaces_DATA = $(interfaces)
+endif
+endif
+endif
+
+interfaces = \
+ avahi-discover.glade
+
EXTRA_DIST = \
$(interfaces) \
avahi-discover.gladep
-endif