summaryrefslogtreecommitdiffstats
path: root/avahi-python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-python/Makefile.am')
-rw-r--r--avahi-python/Makefile.am73
1 files changed, 73 insertions, 0 deletions
diff --git a/avahi-python/Makefile.am b/avahi-python/Makefile.am
new file mode 100644
index 0000000..efb529e
--- /dev/null
+++ b/avahi-python/Makefile.am
@@ -0,0 +1,73 @@
+# $Id$
+
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+AM_CFLAGS=-I$(top_srcdir)
+
+# This cool debug trap works on i386/gcc only
+AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
+
+EXTRA_DIST = \
+ avahi-publish-address.in \
+ avahi-publish-service.in \
+ avahi-bookmarks.in \
+ avahi-discover.in \
+ avahi-discover.desktop.in
+
+SUBDIRS=avahi
+
+if HAVE_PYTHON
+if HAVE_PYTHON_DBUS
+if HAVE_PYGTK
+
+pythonscripts = \
+ avahi-publish-address \
+ avahi-publish-service \
+ avahi-bookmarks \
+ avahi-discover
+
+desktopdir = $(datadir)/applications
+desktop_DATA = avahi-discover.desktop
+
+avahi-discover.desktop: avahi-discover.desktop.in
+ sed -e 's,@bindir\@,$(bindir),g' $< > $@
+ chmod +x $@
+
+avahi-discover: avahi-discover.in
+ sed -e 's,@PYTHON\@,$(PYTHON),g' \
+ -e 's,@interfacesdir\@,$(interfacesdir),g' $< > $@
+ chmod +x $@
+
+avahi-publish-address: avahi-publish-address.in
+ sed -e 's,@PYTHON\@,$(PYTHON),g' $< > $@
+ chmod +x $@
+
+avahi-publish-service: avahi-publish-service.in
+ sed -e 's,@PYTHON\@,$(PYTHON),g' $< > $@
+ chmod +x $@
+
+avahi-bookmarks: avahi-bookmarks.in
+ sed -e 's,@PYTHON\@,$(PYTHON),g' $< > $@
+ chmod +x $@
+
+bin_SCRIPTS = $(pythonscripts)
+CLEANFILES = $(pythonscripts) $(desktop_DATA)
+
+endif
+endif
+endif