summaryrefslogtreecommitdiffstats
path: root/avahi-qt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-qt/Makefile.am')
-rw-r--r--avahi-qt/Makefile.am36
1 files changed, 26 insertions, 10 deletions
diff --git a/avahi-qt/Makefile.am b/avahi-qt/Makefile.am
index ebf454c..f09aca4 100644
--- a/avahi-qt/Makefile.am
+++ b/avahi-qt/Makefile.am
@@ -1,3 +1,22 @@
+# $Id$
+
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
AM_CFLAGS=-I$(top_srcdir)
avahiincludedir=$(includedir)/avahi-qt
@@ -18,17 +37,15 @@ BUILT_SOURCES += qt-watch.moc3
libavahi_qt3_la_SOURCES = \
qt-watch.cpp
-qt-watch.moc3:
- $(MOC_QT3) qt-watch.cpp > $@
-
+qt-watch.moc3: qt-watch.cpp
+ $(MOC_QT3) $^ > $@
libavahi_qt3_la_CPPFLAGS = $(AM_CFLAGS) $(QT3_CFLAGS)
libavahi_qt3_la_LIBADD = $(AM_LDADD) ../avahi-common/libavahi-common.la $(QT3_LIBS)
-libavahi_qt3_la_LDFLAGS = $(AM_LDFLAGS) -export-dynamic -version-info 0:1:0
+libavahi_qt3_la_LDFLAGS = $(AM_LDFLAGS) -export-dynamic -version-info 0:0:0
endif
-
if HAVE_QT4
avahiinclude_HEADERS = \
@@ -42,12 +59,11 @@ BUILT_SOURCES += qt-watch.moc4
libavahi_qt4_la_SOURCES = \
qt-watch.cpp
-qt-watch.moc4:
- $(MOC_QT4) qt-watch.cpp > $@
-
+qt-watch.moc4: qt-watch.cpp
+ $(MOC_QT4) $^ > $@
libavahi_qt4_la_CPPFLAGS = $(AM_CFLAGS) $(QT4_CFLAGS) -DQT4
libavahi_qt4_la_LIBADD = $(AM_LDADD) ../avahi-common/libavahi-common.la $(QT4_LIBS)
-libavahi_qt4_la_LDFLAGS = $(AM_LDFLAGS) -export-dynamic -version-info 0:1:0
+libavahi_qt4_la_LDFLAGS = $(AM_LDFLAGS) -export-dynamic -version-info 0:0:0
-endif \ No newline at end of file
+endif