summaryrefslogtreecommitdiffstats
path: root/avahi-sharp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-sharp/Makefile.am')
-rw-r--r--avahi-sharp/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/avahi-sharp/Makefile.am b/avahi-sharp/Makefile.am
index 070b29c..d361221 100644
--- a/avahi-sharp/Makefile.am
+++ b/avahi-sharp/Makefile.am
@@ -41,6 +41,9 @@ $(ASSEMBLY): $(AVAHISOURCES)
if HAVE_MONO
all: $(ASSEMBLY)
-install-data-hook:
+install-data-hook: $(ASSEMBLY)
$(GACUTIL) /i $(ASSEMBLY) /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
+
+uninstall-hook: $(ASSEMBLY)
+ $(GACUTIL) /u avahi-sharp /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
endif