summaryrefslogtreecommitdiffstats
path: root/avahi-sharp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-sharp/Makefile.am')
-rw-r--r--avahi-sharp/Makefile.am18
1 files changed, 13 insertions, 5 deletions
diff --git a/avahi-sharp/Makefile.am b/avahi-sharp/Makefile.am
index a82f4e6..ffee4cd 100644
--- a/avahi-sharp/Makefile.am
+++ b/avahi-sharp/Makefile.am
@@ -1,6 +1,9 @@
-all: avahi-sharp.dll
+ASSEMBLY = avahi-sharp.dll
+
+CLEANFILES = $(ASSEMBLY) $(ASSEMBLY).mdb
+EXTRA_DIST = $(AVAHISOURCES) avahi.snk
AVAHISOURCES = \
$(srcdir)/AddressResolver.cs \
@@ -12,9 +15,14 @@ AVAHISOURCES = \
$(srcdir)/ServiceBrowser.cs \
$(srcdir)/ServiceResolver.cs \
$(srcdir)/ServiceTypeBrowser.cs \
- Utility.cs
+ $(srcdir)/Utility.cs
+
+$(ASSEMBLY): $(AVAHISOURCES)
+ mcs -keyfile:$(srcdir)/avahi.snk -target:library -o $@ -debug $(AVAHISOURCES) -r:Mono.Posix
-avahi-sharp.dll: $(AVAHISOURCES)
- mcs -target:library -o $@ -debug $(AVAHISOURCES) -r:Mono.Posix
+if HAVE_MONO
+all: $(ASSEMBLY)
-CLEANFILES = avahi-sharp.dll avahi-sharp.dll.mdb
+install-data-hook:
+ $(GACUTIL) /i $(ASSEMBLY) /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
+endif