summaryrefslogtreecommitdiffstats
path: root/avahi-sharp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-sharp/Makefile.am')
-rw-r--r--avahi-sharp/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/avahi-sharp/Makefile.am b/avahi-sharp/Makefile.am
index ffee4cd..e912715 100644
--- a/avahi-sharp/Makefile.am
+++ b/avahi-sharp/Makefile.am
@@ -3,9 +3,10 @@
ASSEMBLY = avahi-sharp.dll
CLEANFILES = $(ASSEMBLY) $(ASSEMBLY).mdb
-EXTRA_DIST = $(AVAHISOURCES) avahi.snk
+EXTRA_DIST = $(AVAHISOURCES) avahi.snk avahi-sharp.pc.in
AVAHISOURCES = \
+ $(srcdir)/AssemblyInfo.cs \
$(srcdir)/AddressResolver.cs \
$(srcdir)/Client.cs \
$(srcdir)/ClientException.cs \
@@ -18,11 +19,19 @@ AVAHISOURCES = \
$(srcdir)/Utility.cs
$(ASSEMBLY): $(AVAHISOURCES)
- mcs -keyfile:$(srcdir)/avahi.snk -target:library -o $@ -debug $(AVAHISOURCES) -r:Mono.Posix
+ mcs -keyfile:$(srcdir)/avahi.snk -target:library -out:$@ -debug $(AVAHISOURCES) -r:Mono.Posix
if HAVE_MONO
all: $(ASSEMBLY)
+pkgcfgdir = $(libdir)/pkgconfig
+pkgcfg_DATA = avahi-sharp.pc
+
+avahi-sharp.pc: avahi-sharp.pc.in
+ sed -e 's,@prefix\@,$(prefix),g' \
+ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
+ -e 's,@libdir\@,$(libdir),g' $< > $@
+
install-data-hook:
$(GACUTIL) /i $(ASSEMBLY) /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
endif