summaryrefslogtreecommitdiffstats
path: root/avahi-sharp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-sharp/Makefile.am')
-rw-r--r--avahi-sharp/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/avahi-sharp/Makefile.am b/avahi-sharp/Makefile.am
index c0866df..3d236e5 100644
--- a/avahi-sharp/Makefile.am
+++ b/avahi-sharp/Makefile.am
@@ -20,13 +20,6 @@
ASSEMBLY = avahi-sharp.dll
CLEANFILES = $(ASSEMBLY) $(ASSEMBLY).mdb
-EXTRA_DIST = \
- $(AVAHISOURCES) \
- avahi.snk \
- avahi-sharp.dll.config \
- avahi-sharp-docs.source \
- en/*.xml \
- en/*/*.xml
AVAHISOURCES = \
$(srcdir)/AssemblyInfo.cs \
@@ -41,6 +34,15 @@ AVAHISOURCES = \
$(srcdir)/ServiceTypeBrowser.cs \
$(srcdir)/Utility.cs
+EXTRA_DIST = \
+ $(AVAHISOURCES) \
+ $(srcdir)/avahi.snk \
+ $(srcdir)/avahi-sharp.dll.config \
+ $(srcdir)/avahi-sharp-docs.source \
+ $(srcdir)/en/*.xml \
+ $(srcdir)/en/*/*.xml
+
+
$(ASSEMBLY): $(AVAHISOURCES)
mcs -keyfile:$(srcdir)/avahi.snk -target:library -out:$@ -debug $(AVAHISOURCES) -r:Mono.Posix