summaryrefslogtreecommitdiffstats
path: root/avahi-ui-sharp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-ui-sharp/Makefile.am')
-rw-r--r--avahi-ui-sharp/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/avahi-ui-sharp/Makefile.am b/avahi-ui-sharp/Makefile.am
index b7f020e..ab58dd2 100644
--- a/avahi-ui-sharp/Makefile.am
+++ b/avahi-ui-sharp/Makefile.am
@@ -37,9 +37,12 @@ $(ASSEMBLY): $(AVAHISOURCES)
$(ASSEMBLY).config: $(ASSEMBLY).config.in
$(srcdir)/gencfg.sh $(top_builddir)/avahi-common/libavahi-common.la < $< > $@
+zssh.exe: zssh.cs
+ mcs -out:$@ zssh.cs -r:./avahi-ui-sharp.dll -pkg:gtk-sharp-2.0 -r:Mono.Posix
+
if HAVE_MONO
if HAVE_DBUS
-all: $(ASSEMBLY) $(ASSEMBLY).config
+all: $(ASSEMBLY) $(ASSEMBLY).config zssh.exe
if HAVE_MONODOC
update-docs: $(ASSEMBLY)