summaryrefslogtreecommitdiffstats
path: root/avahi-utils/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-utils/Makefile.am')
-rw-r--r--avahi-utils/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/avahi-utils/Makefile.am b/avahi-utils/Makefile.am
index 256023c..4b203bd 100644
--- a/avahi-utils/Makefile.am
+++ b/avahi-utils/Makefile.am
@@ -17,8 +17,6 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.
-SUBDIRS=avahi
-
pythonscripts = \
avahi-publish-address \
avahi-publish-service \
@@ -35,9 +33,15 @@ EXTRA_DIST = \
avahi-discover.in \
avahi-bookmarks.in \
avahi-resolve-host-name.in \
- avahi-resolve-address.in
+ avahi-resolve-address.in \
+ avahi-discover.desktop
if HAVE_PYTHON
+SUBDIRS=avahi
+
+desktopdir = $(datadir)/applications
+desktop_DATA = avahi-discover.desktop
+
bin_SCRIPTS = $(pythonscripts)
endif