summaryrefslogtreecommitdiffstats
path: root/avahi-utils/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-utils/Makefile.am')
-rw-r--r--avahi-utils/Makefile.am37
1 files changed, 17 insertions, 20 deletions
diff --git a/avahi-utils/Makefile.am b/avahi-utils/Makefile.am
index f5c69fa..1e10f25 100644
--- a/avahi-utils/Makefile.am
+++ b/avahi-utils/Makefile.am
@@ -17,38 +17,34 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.
-pythonscripts = \
- avahi-publish-address \
- avahi-publish-service \
- avahi-browse \
- avahi-bookmarks \
- avahi-resolve-host-name \
- avahi-resolve-address
-
EXTRA_DIST = \
avahi-publish-address.in \
avahi-publish-service.in \
avahi-browse.in \
avahi-bookmarks.in \
avahi-resolve-host-name.in \
- avahi-resolve-address.in
+ avahi-resolve-address.in \
+ avahi-discover.in \
+ avahi-discover.desktop.in
+SUBDIRS=avahi
if HAVE_PYTHON
if HAVE_PYTHON_DBUS
-SUBDIRS=avahi
+if HAVE_PYGTK
+pythonscripts = \
+ avahi-publish-address \
+ avahi-publish-service \
+ avahi-browse \
+ avahi-bookmarks \
+ avahi-resolve-host-name \
+ avahi-resolve-address \
+ avahi-discover
-if HAVE_PYGTK
desktopdir = $(datadir)/applications
desktop_DATA = avahi-discover.desktop
-pythonscripts += avahi-discover
-
-EXTRA_DIST += \
- avahi-discover.in
- avahi-discover.desktop.in
-
avahi-discover.desktop: avahi-discover.desktop.in
sed -e 's,@bindir\@,$(bindir),g' $< > $@
chmod +x $@
@@ -57,7 +53,6 @@ avahi-discover: avahi-discover.in
sed -e 's,@PYTHON\@,$(PYTHON),g' \
-e 's,@interfacesdir\@,$(interfacesdir),g' $< > $@
chmod +x $@
-endif
avahi-publish-address: avahi-publish-address.in
sed -e 's,@PYTHON\@,$(PYTHON),g' $< > $@
@@ -82,8 +77,10 @@ avahi-resolve-host-name: avahi-resolve-host-name.in
avahi-resolve-address: avahi-resolve-address.in
sed -e 's,@PYTHON\@,$(PYTHON),g' $< > $@
chmod +x $@
-endif
-endif
bin_SCRIPTS = $(pythonscripts)
CLEANFILES = $(pythonscripts) $(desktop_DATA)
+
+endif
+endif
+endif