summaryrefslogtreecommitdiffstats
path: root/avahi-utils/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-utils/Makefile.am')
-rw-r--r--avahi-utils/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/avahi-utils/Makefile.am b/avahi-utils/Makefile.am
index d111a04..d3a1f39 100644
--- a/avahi-utils/Makefile.am
+++ b/avahi-utils/Makefile.am
@@ -90,6 +90,11 @@ bin_PROGRAMS = avahi-browse
avahi_browse_SOURCES = avahi-browse.c sigint.c sigint.h
avahi_browse_CFLAGS = $(AM_CFLAGS)
-avahi_browse_LDADD = $(AM_LDADD) ../avahi-client/libavahi-client.la ../avahi-common/libavahi-common.la
+avahi_browse_LDADD = $(AM_LDADD) ../avahi-client/libavahi-client.la ../avahi-common/libavahi-common.la -lgdbm
+
+if HAVE_GDBM
+avahi_browse_SOURCES += stdb.h stdb.c
+avahi_browse_CFLAGS += -DDATABASE_FILE=\"$(pkgdatadir)/service-types.db\"
+endif
endif