summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e17692d..b5492c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,6 +89,17 @@ if test "x$ENABLE_GTK" = "xyes"; then
fi
AM_CONDITIONAL(ENABLE_GTK, test "x$ENABLE_GTK" = "xyes")
+AC_ARG_ENABLE(doxygen,
+ AC_HELP_STRING([--enable-doxygen],[use doxygen to generate API docs (default=yes)]),
+ [case "${enableval}" in
+ yes) ENABLE_DOXYGEN=yes ;;
+ no) ENABLE_DOXYGEN=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-gtk) ;;
+ esac],
+ [ENABLE_DOXYGEN=yes]) dnl Default value
+
+AM_CONDITIONAL(ENABLE_DOXYGEN, test "x$ENABLE_DOXYGEN" = "xyes")
+
# If using GCC specify some additional parameters
if test "x$GCC" = "xyes" ; then
CFLAGS="$CFLAGS -pipe -W -Wall -pedantic"