summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 11b7bc0..5d0cc76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,6 +84,18 @@ if test "x$ENABLE_GTK" = "xyes"; then
PKG_CHECK_MODULES(GLADE20, [ libglade-2.0 >= 2.4.0 ])
AC_SUBST(GLADE20_CFLAGS)
AC_SUBST(GLADE20_LIBS)
+
+ DATADIRNAME=share
+ if test "x${prefix}" = "xNONE"; then
+ AC_DEFINE_UNQUOTED(INTERFACES_DIR, "${ac_default_prefix}/${DATADIRNAME}/${PACKAGE}/interfaces/", [path where glade files will be installed])
+ interfacesdir="${ac_default_prefix}/${DATADIRNAME}/${PACKAGE}/interfaces/"
+ AC_SUBST(interfacesdir)
+ else
+ AC_DEFINE_UNQUOTED(INTERFACES_DIR, "${prefix}/${DATADIRNAME}/${PACKAGE}/interfaces/", [path where glade files will be installed])
+ interfacesdir="${prefix}/${DATADIRNAME}/${PACKAGE}/interfaces/"
+ AC_SUBST(interfacesdir)
+ fi
+
fi
AM_CONDITIONAL(ENABLE_GTK, test "x$ENABLE_GTK" = "xyes")