summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8db8c53..ba369a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,7 +74,6 @@ case "$host" in
;;
*-linux*)
AC_DEFINE([LINUX],[],[ Support for GNU/Linux])
- AC_DEFINE([HAVE_NETLINK],[],[ Support for netlink.h])
avahi_platform=linux
;;
*-freebsd* | *-kfreebsd*-gnu)
@@ -87,7 +86,15 @@ case "$host" in
;;
esac
-AM_CONDITIONAL(HAVE_NETLINK, [ test x"$avahi_platform" = xlinux ])
+AC_CHECK_HEADER(linux/netlink.h,
+HAVE_NETLINK=yes
+AC_DEFINE([HAVE_NETLINK],[],[Support for Linux netlink])
+, [], [
+#include <sys/socket.h>
+#include <asm/types.h>
+])
+
+AM_CONDITIONAL(HAVE_NETLINK, [ test x"$HAVE_NETLINK" = xyes ])
#
# Detecting the linux distribution for specific things like init scripts.