summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2286b80..cbfa2b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,7 +84,7 @@ if test x"$enable_ssp" = x"yes"; then
AC_MSG_CHECKING([whether stack-smashing protection is available])
ssp_old_cflags="$CFLAGS"
ssp_old_ldflags="$LDFLAGS"
- CFLAGS="$CFLAGS -fstack-protector-all -fPIC"
+ CFLAGS="$CFLAGS -Werror -fstack-protector-all -fPIC"
LDFLAGS="$LDFLAGS -Wl,-z,defs"
cat confdefs.h > conftest.c
cat >>conftest.c <<_ACEOF