summaryrefslogtreecommitdiffstats
path: root/initscript/darwin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'initscript/darwin/Makefile.am')
-rw-r--r--initscript/darwin/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/initscript/darwin/Makefile.am b/initscript/darwin/Makefile.am
new file mode 100644
index 0000000..facc9d5
--- /dev/null
+++ b/initscript/darwin/Makefile.am
@@ -0,0 +1,40 @@
+# $Id$
+
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+initddir = /System/Library/LaunchDaemons/
+
+EXTRA_DIST = \
+ org.freedesktop.avahi-daemon.plist.in \
+ org.freedesktop.avahi-dnsconfd.plist.in
+
+initd_SCRIPTS = \
+ org.freedesktop.avahi-daemon.plist \
+ org.freedesktop.avahi-dnsconfd.plist
+
+CLEANFILES = \
+ org.freedesktop.avahi-daemon.plist \
+ org.freedesktop.avahi-dnsconfd.plist
+
+org.freedesktop.avahi-daemon.plist: org.freedesktop.avahi-daemon.plist.in
+ sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod +x $@
+
+org.freedesktop.avahi-dnsconfd.plist: org.freedesktop.avahi-dnsconfd.plist.in
+ sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod +x $@