summaryrefslogtreecommitdiffstats
path: root/initscript/suse/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'initscript/suse/Makefile.am')
-rw-r--r--initscript/suse/Makefile.am38
1 files changed, 33 insertions, 5 deletions
diff --git a/initscript/suse/Makefile.am b/initscript/suse/Makefile.am
index 3aa8431..e18f0f6 100644
--- a/initscript/suse/Makefile.am
+++ b/initscript/suse/Makefile.am
@@ -1,6 +1,34 @@
-if ENABLE_DBUS
-dbusinitddir = $(sysconfdir)/init.d
-dbusinitd_SCRIPTS = avahi-daemon
+# $Id$
-EXTRA_DIST = $(dbusinitd_SCRIPTS)
-endif
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+initddir = $(sysconfdir)/init.d
+
+EXTRA_DIST = avahi-daemon.in avahi-dnsconfd.in
+
+initd_SCRIPTS = avahi-daemon avahi-dnsconfd
+
+CLEANFILES = avahi-daemon avahi-dnsconfd
+
+avahi-daemon: avahi-daemon.in
+ sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod +x $@
+
+avahi-dnsconfd: avahi-dnsconfd.in
+ sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod +x $@