summaryrefslogtreecommitdiffstats
path: root/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 885f9d8..39ebcd9 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -21,7 +21,8 @@ pkgsysconfdir=$(sysconfdir)/avahi
servicedir=$(pkgsysconfdir)/services
man_MANS = \
- avahi-daemon.8
+ avahi-daemon.8 \
+ avahi-dnsconfd.8
if HAVE_PYTHON
@@ -44,7 +45,8 @@ noinst_DATA = \
avahi-resolve-host-name.1.xml \
avahi-daemon.8.xml \
avahi-discover.1.xml \
- avahi-bookmarks.1.xml
+ avahi-bookmarks.1.xml \
+ avahi-dnsconfd.8.xml
EXTRA_DIST = \
$(man_MANS) \
@@ -56,6 +58,7 @@ EXTRA_DIST = \
avahi-daemon.8.xml.in \
avahi-discover.1.xml.in \
avahi-bookmarks.1.xml.in \
+ avahi-dnsconfd.8.xml.in \
xmltoman.css \
xmltoman.xsl \
xmltoman.dtd
@@ -97,6 +100,12 @@ avahi-bookmarks.1.xml: avahi-bookmarks.1.xml.in Makefile
sed -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
-e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
+avahi-dnsconfd.8.xml: avahi-dnsconfd.8.xml.in Makefile
+ sed -e 's,@pkgsysconfdir\@,$(pkgsysconfdir),g' \
+ -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
+ -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
+
+
if USE_XMLTOMAN
CLEANFILES += $(man_MANS)
@@ -125,4 +134,7 @@ avahi-discover.1: avahi-discover.1.xml Makefile
avahi-bookmarks.1: avahi-bookmarks.1.xml Makefile
xmltoman $< > $@
+avahi-dnsconfd.8: avahi-dnsconfd.8.xml Makefile
+ xmltoman $< > $@
+
endif