summaryrefslogtreecommitdiffstats
path: root/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am33
1 files changed, 32 insertions, 1 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index f6bbae0..756d481 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -42,7 +42,9 @@ noinst_DATA = \
avahi-daemon.conf.5.xml \
avahi-dnsconfd.action.8.xml \
avahi.service.5.xml \
- avahi.hosts.5.xml
+ avahi.hosts.5.xml \
+ avahi-autoipd.8.xml \
+ avahi-autoipd.action.8.xml
CLEANFILES = \
$(noinst_DATA)
@@ -62,6 +64,16 @@ man_MANS += \
endif
endif
+if ENABLE_AUTOIPD
+if HAVE_LIBDAEMON
+
+man_MANS += \
+ avahi-autoipd.8 \
+ avahi-autoipd.action.8
+
+endif
+endif
+
avahi-browse.1.xml: avahi-browse.1.xml.in Makefile
sed -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
-e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
@@ -118,6 +130,17 @@ avahi.hosts.5.xml: avahi.hosts.5.xml.in Makefile
-e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
-e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
+avahi-autoipd.action.8.xml: avahi-autoipd.action.8.xml.in Makefile
+ sed -e 's,@pkgsysconfdir\@,$(pkgsysconfdir),g' \
+ -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
+ -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
+
+avahi-autoipd.8.xml: avahi-autoipd.8.xml.in Makefile
+ sed -e 's,@pkgsysconfdir\@,$(pkgsysconfdir),g' \
+ -e 's,@PACKAGE_BUGREPORT\@,$(PACKAGE_BUGREPORT),g' \
+ -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' $< > $@
+
+
if USE_XMLTOMAN
CLEANFILES += $(man_MANS)
@@ -158,6 +181,12 @@ avahi.service.5: avahi.service.5.xml Makefile
avahi.hosts.5: avahi.hosts.5.xml Makefile
xmltoman $< > $@
+avahi-autoipd.action.8: avahi-autoipd.action.8.xml Makefile
+ xmltoman $< > $@
+
+avahi-autoipd.8: avahi-autoipd.8.xml Makefile
+ xmltoman $< > $@
+
xmllint: $(noinst_DATA)
for f in $(noinst_DATA) ; do \
xmllint --noout --valid "$$f" || exit 1 ; \
@@ -181,6 +210,8 @@ EXTRA_DIST = \
avahi-dnsconfd.action.8.xml.in \
avahi.service.5.xml.in \
avahi.hosts.5.xml.in \
+ avahi-autoipd.action.8.xml.in \
+ avahi-autoipd.8.xml.in \
xmltoman.css \
xmltoman.xsl \
xmltoman.dtd