summaryrefslogtreecommitdiffstats
path: root/service-type-database/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'service-type-database/Makefile.am')
-rw-r--r--service-type-database/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/service-type-database/Makefile.am b/service-type-database/Makefile.am
new file mode 100644
index 0000000..171de57
--- /dev/null
+++ b/service-type-database/Makefile.am
@@ -0,0 +1,38 @@
+# $Id$
+#
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+EXTRA_DIST=build-db.in service-types
+
+pkgdata_DATA=service-types
+
+if HAVE_PYTHON
+
+noinst_SCRIPTS=build-db
+pkgdata_DATA+=service-types.db
+
+build-db: build-db.in
+ sed -e 's,@PYTHON\@,$(PYTHON),g' $< > $@
+ chmod +x $@
+
+service-types.db: service-types
+ $(PYTHON) build-db $<
+
+CLEANFILES = service-types.db build-db
+
+endif