summaryrefslogtreecommitdiffstats
path: root/audio/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2007-04-08 19:56:52 +0000
committerMarcel Holtmann <marcel@holtmann.org>2007-04-08 19:56:52 +0000
commitfa83abed5f41a567175c9b734fba55fa979f455a (patch)
tree0fa0e638d73916db799ba2f81c42ec32124099ca /audio/Makefile.am
parent232610dea7be7fc8ca6a6bd22a02eca4a072b9c1 (diff)
Only provide generic audio service
Diffstat (limited to 'audio/Makefile.am')
-rw-r--r--audio/Makefile.am21
1 files changed, 7 insertions, 14 deletions
diff --git a/audio/Makefile.am b/audio/Makefile.am
index 16c4f245..cbb27956 100644
--- a/audio/Makefile.am
+++ b/audio/Makefile.am
@@ -1,19 +1,19 @@
-if HEADSETSERVICE
+if AUDIOSERVICE
if CONFIGFILES
confdir = $(sysconfdir)/bluetooth
-conf_DATA = headset.service
+conf_DATA = audio.service
endif
servicedir = $(libdir)/bluetooth
-service_PROGRAMS = bluetoothd-service-headset
+service_PROGRAMS = bluetoothd-service-audio
-bluetoothd_service_headset_SOURCES = headset.c
+bluetoothd_service_audio_SOURCES = manager.h manager.c headset.c
-bluetoothd_service_headset_LDADD = $(top_builddir)/common/libhelper.a \
- @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
+bluetoothd_service_audio_LDADD = $(top_builddir)/common/libhelper.a \
+ @SBC_LIBS@ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
endif
if ALSA
@@ -30,17 +30,10 @@ libasound_module_ctl_bluetooth_la_LDFLAGS = -module -avoid-version -export-dynam
libasound_module_ctl_bluetooth_la_LIBADD = @ALSA_LIBS@
endif
-noinst_PROGRAMS = bluetoothd-service-audio
-
-bluetoothd_service_audio_SOURCES = main.c manager.h manager.c
-
-bluetoothd_service_audio_LDADD = $(top_builddir)/common/libhelper.a \
- @SBC_LIBS@ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
-
AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @ALSA_CFLAGS@ @SBC_CFLAGS@
INCLUDES = -I$(top_srcdir)/common
-EXTRA_DIST = headset.service audio-api.txt asound.conf
+EXTRA_DIST = audio.service audio-api.txt asound.conf
MAINTAINERCLEANFILES = Makefile.in