summaryrefslogtreecommitdiffstats
path: root/audio/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2007-08-24 16:55:28 +0000
committerMarcel Holtmann <marcel@holtmann.org>2007-08-24 16:55:28 +0000
commitdbf29a633849e5f59ca097fcc3d810a320f8d16a (patch)
treef854f0777b3d569c8eb6a552457330d99c0d2f4a /audio/Makefile.am
parentc0de0ea2dce19830f16a731266e4299c60e5b1d7 (diff)
Add checks and skeleton for PulseAudio plugin
Diffstat (limited to 'audio/Makefile.am')
-rw-r--r--audio/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/audio/Makefile.am b/audio/Makefile.am
index ce16cd12..42fd1590 100644
--- a/audio/Makefile.am
+++ b/audio/Makefile.am
@@ -34,6 +34,17 @@ libasound_module_ctl_bluetooth_la_LIBADD = @ALSA_LIBS@
libasound_module_ctl_bluetooth_la_CFLAGS = @ALSA_CFLAGS@
endif
+if PULSE
+pulsedir = $(libdir)/pulse-0.9/modules
+
+noinst_LTLIBRARIES = module-bluetooth-sink.la
+
+module_bluetooth_sink_la_SOURCES = module-bluetooth-sink.c ipc.h
+module_bluetooth_sink_la_LDFLAGS = -module -avoid-version
+module_bluetooth_sink_la_LIBADD = @SBC_LIBS@ @PULSE_LIBS@
+module_bluetooth_sink_la_CFLAGS = @PULSE_CFLAGS@ @SBC_CFLAGS@
+endif
+
if GSTREAMER
gstreamerdir = $(libdir)/gstreamer-0.10