summaryrefslogtreecommitdiffstats
path: root/audio/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2007-08-22 14:09:24 +0000
committerMarcel Holtmann <marcel@holtmann.org>2007-08-22 14:09:24 +0000
commit674a1d6355ebd5c1e9ffc2e7663b747f60ac70b5 (patch)
treec28034068b828d30507e2440e1f9008440684a83 /audio/Makefile.am
parent656d22e0c137ed29481d164c018c58137b610e52 (diff)
Add skeleton for GStreamer plugin
Diffstat (limited to 'audio/Makefile.am')
-rw-r--r--audio/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/audio/Makefile.am b/audio/Makefile.am
index cc73f9be..78352073 100644
--- a/audio/Makefile.am
+++ b/audio/Makefile.am
@@ -26,14 +26,28 @@ alsa_LTLIBRARIES = libasound_module_pcm_bluetooth.la libasound_module_ctl_blueto
libasound_module_pcm_bluetooth_la_SOURCES = pcm_bluetooth.c ipc.h
libasound_module_pcm_bluetooth_la_LDFLAGS = -module -avoid-version -export-dynamic
libasound_module_pcm_bluetooth_la_LIBADD = @SBC_LIBS@ @ALSA_LIBS@
+libasound_module_pcm_bluetooth_la_CFLAGS = @ALSA_CFLAGS@ @SBC_CFLAGS@
libasound_module_ctl_bluetooth_la_SOURCES = ctl_bluetooth.c ipc.h
libasound_module_ctl_bluetooth_la_LDFLAGS = -module -avoid-version -export-dynamic
libasound_module_ctl_bluetooth_la_LIBADD = @ALSA_LIBS@
+libasound_module_ctl_bluetooth_la_CFLAGS = @ALSA_CFLAGS@
endif
+
+if GSTREAMER
+gstreamerdir = $(libdir)/gstreamer-0.10
+
+gstreamer_LTLIBRARIES = libgstbluetooth.la
+
+libgstbluetooth_la_SOURCES = gstbluetooth.c ipc.h
+libgstbluetooth_la_LDFLAGS = -module -avoid-version -export-dynamic -no-undefined
+libgstbluetooth_la_LIBADD = @SBC_LIBS@ @GSTREAMER_LIBS@
+libgstbluetooth_la_CFLAGS = @GSTREAMER_CFLAGS@ @SBC_CFLAGS@
+endif
+
endif
-AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @ALSA_CFLAGS@ @SBC_CFLAGS@
+AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@
INCLUDES = -I$(top_srcdir)/common