summaryrefslogtreecommitdiffstats
path: root/audio/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2007-04-04 09:39:23 +0000
committerMarcel Holtmann <marcel@holtmann.org>2007-04-04 09:39:23 +0000
commite7bd84e89e0af0cd2c2390bf7a173f90a473fc62 (patch)
tree5935ff4fbd5961ddc9ba06aa7804c8fe0076bd8e /audio/Makefile.am
parenta36be2a103e95b04d5b348c83b41dc8c06439990 (diff)
Add skeleton for generic ALSA plugins
Diffstat (limited to 'audio/Makefile.am')
-rw-r--r--audio/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/audio/Makefile.am b/audio/Makefile.am
index 4de6d59f..1f8d70d7 100644
--- a/audio/Makefile.am
+++ b/audio/Makefile.am
@@ -16,6 +16,20 @@ bluetoothd_service_headset_LDADD = $(top_builddir)/common/libhelper.a \
@GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
endif
+if ALSA
+alsadir = $(libdir)/alsa-lib
+
+alsa_LTLIBRARIES = libasound_module_pcm_bluetooth.la libasound_module_ctl_bluetooth.la
+
+libasound_module_pcm_bluetooth_la_SOURCES = pcm_bluetooth.c
+libasound_module_pcm_bluetooth_la_LDFLAGS = -module -avoid-version -export-dynamic
+libasound_module_pcm_bluetooth_la_LIBADD = @ALSA_LIBS@
+
+libasound_module_ctl_bluetooth_la_SOURCES = ctl_bluetooth.c
+libasound_module_ctl_bluetooth_la_LDFLAGS = -module -avoid-version -export-dynamic
+libasound_module_ctl_bluetooth_la_LIBADD = @ALSA_LIBS@
+endif
+
noinst_PROGRAMS = bluetoothd-service-audio
bluetoothd_service_audio_SOURCES = main.c manager.h manager.c
@@ -23,7 +37,7 @@ bluetoothd_service_audio_SOURCES = main.c manager.h manager.c
bluetoothd_service_audio_LDADD = $(top_builddir)/common/libhelper.a \
@SBC_LIBS@ @GLIB_LIBS@ @DBUS_LIBS@ @BLUEZ_LIBS@
-AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @SBC_CFLAGS@
+AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@ @ALSA_CFLAGS@ @SBC_CFLAGS@
INCLUDES = -I$(top_srcdir)/common