summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2004-04-03 06:04:35 +0000
committerMarcel Holtmann <marcel@holtmann.org>2004-04-03 06:04:35 +0000
commit1d3715db11f573060cb02a2b7b7c44f06607d337 (patch)
tree53e9b7eca91253c4c19e2cba3679d3c6084000a7 /configure.in
parentb215047988241418ccbcaa41c07366ea637678c7 (diff)
Update BlueZ library configuration
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in46
1 files changed, 6 insertions, 40 deletions
diff --git a/configure.in b/configure.in
index 3115ee0e..0c26d6a3 100644
--- a/configure.in
+++ b/configure.in
@@ -33,52 +33,18 @@ AC_PROG_INSTALL
AC_PROG_YACC
AM_PROG_LEX
-AC_ARG_WITH(bluez-libs,
- --with-bluez-libs=DIR BlueZ libraries,
- BLUEZ_LIBDIR="$withval",
- BLUEZ_LIBDIR='../libs/src /usr/lib'
-)
+AC_ARG_WITH(bluez, [ --with-bluez=DIR BlueZ library is installed in DIR], [
+ bluez_includes=$withval/include
+ bluez_libraries=$withval/lib
+])
-AC_ARG_WITH(bluez-includes,
- --with-bluez-includes=DIR BlueZ header files,
- BLUEZ_INCDIR="$withval",
- BLUEZ_INCDIR='../libs/include /usr/include'
-)
+AC_PATH_BLUEZ
-AC_ARG_ENABLE(dbus,
- --enable-dbus use D-BUS,
+AC_ARG_ENABLE(dbus, [ --enable-dbus use D-BUS],
BLUEZ_DBUS="$enableval",
BLUEZ_DBUS="no"
)
-AC_SEARCH_HEADERS(bluetooth/bluetooth.h, $BLUEZ_INCDIR,,
- AC_MSG_ERROR(Bluetooth headers not found.
- Please compile and install bluez-libs package.)
-)
-
-AC_SEARCH_LIB(bluetooth, hci_open_dev, $BLUEZ_LIBDIR,,
- AC_MSG_ERROR(Bluetooth library not found.
- Please compile and install bluez-libs package.)
-)
-
-AC_SUBST(DISTRO)
-AC_SUBST(PCMCIA)
-
-DISTRO=unknown
-
-if test "$cross_compiling" != yes; then
- AC_TEST_FILE(/etc/redhat-release, DISTRO=redhat)
- AC_TEST_FILE(/etc/mandrake-release, DISTRO=redhat)
- AC_TEST_FILE(/etc/debian_version, DISTRO=debian)
-fi
-
-AC_ARG_ENABLE(pcmcia,
- --enable-pcmcia Always install PCMCIA support files,
- [PCMCIA=pcmcia],
- [ if test "$cross_compiling" != yes; then
- AC_TEST_DIR(/etc/pcmcia, PCMCIA=pcmcia, PCMCIA=)
- fi ])
-
if test x"$BLUEZ_DBUS" == "xyes"; then
PKG_CHECK_MODULES(DBUS, dbus-1, have_dbus=yes, have_dbus=no)