summaryrefslogtreecommitdiffstats
path: root/cups/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2007-06-07 10:07:13 +0000
committerMarcel Holtmann <marcel@holtmann.org>2007-06-07 10:07:13 +0000
commit0ab5125673b1a969c8cb098caab2c0009c79f29c (patch)
tree4ae80f55b38cde6fbd6f0e6a77d4011573c8a420 /cups/Makefile.am
parent16441b2106ab7e7712ed21dd7a68ba308afc9942 (diff)
Let CUPS plugin discover printers in range
Diffstat (limited to 'cups/Makefile.am')
-rw-r--r--cups/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/cups/Makefile.am b/cups/Makefile.am
index 7d5cadf4..0573a4af 100644
--- a/cups/Makefile.am
+++ b/cups/Makefile.am
@@ -3,13 +3,19 @@ if CUPS
cupsdir = $(libdir)/cups/backend
cups_PROGRAMS = bluetooth
-else
-noinst_PROGRAMS = bluetooth
-endif
bluetooth_SOURCES = main.c sdp.c spp.c hcrp.c
-bluetooth_LDADD = @BLUEZ_LIBS@
-AM_CFLAGS = @BLUEZ_CFLAGS@
+bluetooth_LDADD = $(top_builddir)/common/libhelper.a \
+ @DBUS_LIBS@ @GLIB_LIBS@ @BLUEZ_LIBS@
+
+if EXPAT
+bluetooth_LDADD += -lexpat
+endif
+endif
+
+AM_CFLAGS = @BLUEZ_CFLAGS@ @DBUS_CFLAGS@ @GLIB_CFLAGS@
+
+INCLUDES = -I$(top_srcdir)/common
MAINTAINERCLEANFILES = Makefile.in