summaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2007-01-19 16:19:50 +0000
committerMarcel Holtmann <marcel@holtmann.org>2007-01-19 16:19:50 +0000
commit06e0a7f62e2f594784c01ce232e040dae333dc18 (patch)
treed3bb036a6dbfa00dbf34d7781459996d732c10d0 /daemon/Makefile.am
parent87113c3bda9245ad758ce75d8cec04ca303faed3 (diff)
Make the echo service useful for testing again
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 2f13ade2..9f7a4a0e 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -7,7 +7,7 @@ glib_cflags =
glib_ldadd =
endif
-noinst_PROGRAMS = bluetoothd
+noinst_PROGRAMS = bluetoothd bluetoothd_echo
bluetoothd_SOURCES = main.c system.h \
manager.h manager.c database.h database.c \
@@ -17,6 +17,11 @@ bluetoothd_LDADD = $(glib_ldadd) @DBUS_LIBS@ @BLUEZ_LIBS@ \
$(top_builddir)/sdpd/libsdpserver.a \
$(top_builddir)/common/libhelper.a
+bluetoothd_echo_SOURCES = echo.c
+
+bluetoothd_echo_LDADD = $(glib_ldadd) @DBUS_LIBS@ @BLUEZ_LIBS@ \
+ $(top_builddir)/common/libhelper.a
+
if EXPAT
bluetoothd_LDADD += -lexpat
endif