summaryrefslogtreecommitdiffstats
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2006-10-26 16:17:13 +0000
committerMarcel Holtmann <marcel@holtmann.org>2006-10-26 16:17:13 +0000
commit9f8d1c90aab3dd84b6f0abc7bb726c0bc79c0f92 (patch)
tree1bd6ca6a0c123f1f8cc14dfc429df8f3a6f18dff /daemon/Makefile.am
parentd900a907a0c43e31b84ee5b9aabe5ab7a114052e (diff)
Add skeleton for example echo service
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 6d5bf02d..51855d7b 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -1,14 +1,27 @@
if GLIB
-noinst_PROGRAMS = bluetoothd
+noinst_PROGRAMS = bluetoothd bt.echod
bluetoothd_SOURCES = main.c
bluetoothd_LDADD = @GLIB_LIBS@ @BLUEZ_LIBS@ $(top_builddir)/common/libhelper.a
+bt_echod_SOURCES = echo.c
+
+bt_echod_LDADD = @GLIB_LIBS@ @BLUEZ_LIBS@
+
AM_CFLAGS = @BLUEZ_CFLAGS@ @GLIB_CFLAGS@
INCLUDES = -I$(top_srcdir)/common
+
+BUILT_SOURCES = service-agent-glue.h
+
+CLEANFILES = $(BUILT_SOURCES)
endif
+EXTRA_DIST = service-agent.xml
+
MAINTAINERCLEANFILES = Makefile.in
+
+service-agent-glue.h: service-agent.xml
+ $(DBUS_BINDING_TOOL) --prefix=service_agent --mode=glib-server --output=$@ $(srcdir)/$<